Some requests to the API are failing to write data

Incident Report for Qualified

Postmortem

A new database version caused a configuration mismatch that has since been optimized. The issue was related to retryable writes at the database level, with an issue causing retries with the same transaction ID to be handled in the same database session. We have deployed a fix which has completely resolved the issue.

Posted Feb 24, 2021 - 21:09 UTC

Resolved

A portion of requests that need to write data to our database are failing. The UI is configured to retry these requests, so should be minimal impact to user experience.
Posted Feb 24, 2021 - 20:00 UTC