Slow performance do to database service issues

Incident Report for Qualified

Resolved

This incident has been resolved.
Posted Jan 02, 2022 - 02:44 UTC

Investigating

We are currently investigating this issue.
Posted Jan 02, 2022 - 01:15 UTC
This incident affected: API and Background Processing (Submissions Queue).